Fandom

Why We Protest Scientology Wiki

Howto/Strip metadata from sensitive files

238pages on
this wiki
Add New Page
Talk0 Share

Metadata is basically, "data about data". Metadata descries what a file contains.

How To Remove MetadataEdit

From Microsoft Word 2000 DocumentsEdit

How to Remove Your User Name from Your DocumentsEdit

To view or change your user name, follow these steps:

  • Click Options on the Tools menu. Select the User Information tab.

The Following boxes appear:
Name
Initials
Mailing Address

  • If you do not want any of this information to appear in your documents, enter non-identifying strings or spaces in the appropriate edit boxes, and then click OK to accept the changes.

How to Remove Personal Summary InformationEdit

When you create or save a document in Word, summary information may be saved in the document. There are several methods you can use to access this information:

  • Open the document. On the File menu, click Properties . The Summary , Statistics , Contents , and Custom tabs may all contain various properties such as your name, your manager's name, and your company name.
  • In the Windows Explorer, right-click the document, and then click Properties on the shortcut menu. The tabs in the Properties dialog box may contain information.
  • It is possible to use a Visual Basic for Applications macro or other program code to read the properties shown in the Properties dialog box.


To clear summary information from an existing document or template, follow these steps:

  • Open the document or template
  • On the File menu, click Properties.
  • On the Summary tab, clear the Author, Manager, Company, and any other edit boxes that you do not want to distribute.
  • On the Custom tab, delete any properties that contain information that you do not want to distribute.
  • When you are finished, click OK. Click Save on the File menu, and then click Close on the File menu.


After you have completed these steps, the document should not contain summary properties.

How to Remove Personal Summary Information When Connected to a NetworkEdit

If you are logged on to a network, your network user name may appear in the Author edit box on the Summary tab and in the Last saved by field on the Statistics tab, when you save a document. This can occur even if you have removed all other personal information from your computer.
To remove summary information from a document when you are on a network:

  • If the document is stored on a network server, copy it to your local hard disk.
  • Start your computer, but do NOT log on to your network. When you see the network logon dialog box, click Cancel or press ESCAPE.
  • Open the document.
  • On the File menu, click Properties.
  • On the Summary tab, clear the Author, Manager, Company, and any other edit boxes that contain information you do not want to distribute.
  • On the Custom tab, delete any properties that contain information that you do not want to distribute.
  • When you are finished, click OK. Click Save on the File menu. Then click Close on the File menu.


When you log on to the network, do not open the file. If you do, your network user name may be written into the file. However, you can use the Windows Explorer to copy the file to either a network server or a floppy disk.

How to Remove Comments in DocumentsEdit

Microsoft Word offers the ability to add comments to documents. Typically, comments contain the name of the person who created them, so that you can tell who wrote them.
Comments typically appear as a highlighted section of text; you can right-click inside the comment, and then click Delete Comment on the shortcut menu.
Any new comments that you create should not contain your user name, because you have removed it from your Options dialog box, as shown earlier.

From Microsoft Word 2002Edit

How to Automatically Remove Personal Information When You SaveEdit

You can now automatically remove personal information from a Word document when you save the document. To turn this option on, follow these steps:

  • On the Tools menu, click Options.
  • On the Security tab, click to select the Remove personal information from this file on save check box under Privacy options, and then click OK.

How to Manually Remove Your User Name from Your DocumentsEdit

To view or change your user name, follow these steps:

  • On the Tools menu, click Options, and then click the User Information tab.


The following text boxes appear:
Name
Initials
Mailing Address

  • If you do not want any of this information to appear in your documents, enter non-identifying strings or spaces in the appropriate text boxes, and then click OK to accept the changes.

How to Manually Remove Personal Summary InformationEdit

To clear summary information from an existing document or template, follow these steps:

  • Open the document or template.
  • On the File menu, click Properties.
  • On the Summary tab, click to clear the Author, Manager, Company, and any other text boxes that you do not want to distribute.
  • On the Custom tab, delete any properties that contain information that you do not want to distribute.
  • Click OK.


On the File menu, click Save, and then click Close.
After you complete these steps, the document will not contain summary properties.

From Microsoft Excel WorkbooksEdit

How to Delete Your User Name from Your ProgramsEdit

To view or change your user name, follow these steps:

  • On the Tools menu, click Options. Click the General tab. You see the User name edit box.
  • If you do not want any of this information to appear in your workbooks, type non-identifying information or spaces in the edit box, and then click OK to accept the changes.


Any new workbooks that you create will contain this information, rather than the default values that you typed when you first installed Office. However, existing workbooks may already contain this information.

How to Remove Personal Summary InformationEdit

To remove summary information from an existing workbook or template, follow these steps:

  • Open the workbook or template.
  • On the File menu, click Properties.
  • On the Summary tab, delete any text in the Author, Manager, Company, and other edit boxes that you do not want to distribute.
  • On the Custom tab, delete any properties that contain information that you do not want to distribute.
  • When you are finished, click OK. On the File menu, click Save.
  • On the File menu, click Close.


After you complete these steps, the workbook will not contain summary properties.

From Microsoft PowerPoint PresentationsEdit

How to Delete Your User Name from Your ProgramsEdit

To delete your user name, follow these steps:

  • On the Tools menu, click Options. Click the General tab. You see the Name and Initials edit boxes.
  • If you do not want any of this information to appear in your presentations, type nonidentifying information or spaces in the appropriate edit box or boxes, and then click OK to accept the changes.


Any new presentations that you create will contain this new information, rather than the default values that you typed when you first installed Office. However, existing presentations may already contain this information.

How to Delete Personal Summary InformationEdit

To delete summary information from an existing presentation, follow these steps:

  • Open the presentation.
  • On the File menu, click Properties.
  • On the Summary tab, delete the Author, Manager, Company, and any other information that you do not want to distribute.
  • On the Custom tab, delete any properties that contain information that you do not want to distribute.
  • When you finish, click OK. On the File menu, click Save.
  • On the File menu, click Close.


After you complete these steps, the presentation should not contain summary properties.

From JPEGEdit

Using PhotoshopEdit

In Photoshop, you can strip metadata from a JPG by creating a blank document of the same size, and then pasting the original into it:

  • Select the entire photo, press CTRL(CMD)+A
  • Go to the empty picture, and press CTRL(CMD)+V to paste
  • Flatten the new photo
    • Go to the Layers menu
    • Right clicking on the background layer and selecting Flatten Layers
  • When you save the photo, the metadate will have been left out.

Using Batch MethodEdit

If you want to remove metadata from JPEG files, you should keep in mind that these data can provide useful information (such as focal length, shutter speed, etc.). Therefore, you should never remove them from your original pictures. Instead, you should make a copy of the picture you want to publish and then remove the metadata from this copy.

Using jheadEdit

Several software tools support the removal of metadata. A recommendable one is jhead. It is a free open source program that runs on a variety of operating systems (Windows/Linux/BSD/Mac). Because jhead is a command line tool, it is particularly suitable to be used with batch files.
Less experienced users should adhere to this step-by-step guide (Windows):

  • Create the directory C:\jpeg.
  • Copy all pictures whose metadata you want to remove to C:\jpeg.
  • Download the program file jhead.exe to C:\jpeg.
  • Click on "Start" and then "Execute...".
    • Windows 95/98/Me: Type command.com and click on "OK".
    • Windows NT/2000/XP: Type cmd.exe and click on "OK".
  • Change to C:\jpeg. To do so, type the following (the words in brackets are instructions to be executed, not to be typed):
    • c: (press return)
    • cd\ (press return)
    • cd jhead (press return)
  • To remove all metadata of all JPEG files in "C:\jpeg", type:
    • jhead -purejpg * (press return)

Using IrfanViewEdit

If you prefer programs with a graphical user interface, you should try IrfanView. It is a free program for Windows that allows you to view and edit images. Besides IrfanView itself, you need the plug-in "Lossless JPG Transformations". More detailed information about how to install this plug-in can be found on IrfanView's homepage.
Less experienced users should stick to these instructions:

  • Download IrfanView and its plug-ins and install them.
  • Create the directory C:\jpeg.
  • Copy all pictures whose metadata you want to remove to C:\jpeg.
  • Start IrfanView. In its menu bar, click on "File" and then "Thumbnails".
  • A new window has opened. In its left column, select C:\jpeg. The right column will now show small preview images of all pictures of C:\jpeg.
  • Select all pictures. To do so, click on "Options" in the menu bar of the new window and then "Select all".
  • In the same menu bar, click on "File", "JPG Lossless Operations" and then "Lossless transformation with selected thumbs...".
  • A new window has opened. In the section "Transformation", select "None (can be used for optimizing and cleaning)".
  • In the section "JPG APP marker options", select "Clean all APP markers".
  • Finally, click on "Start".

External ResourcesEdit

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.